ラズベリーパイ+pythonを使ってみる – かんたんなwebアプリがパパっと作れる flask のインストール –

スポンサーリンク

flask(フラスク)=pythonでよく使われているwebアプリケーションフレームワークです。PHPでいうところのCakePHPをもっとかんたんにした感じです。RubyでいうとSinatraです

インストール

sudo pip install flask

ログ

sudo pip install flask
Downloading/unpacking flask
  Downloading Flask-0.10.1.tar.gz (544Kb): 544Kb downloaded
  Running setup.py egg_info for package flask

    warning: no files found matching '*' under directory 'tests'
    warning: no previously-included files matching '*.pyc' found under directory 'docs'
    warning: no previously-included files matching '*.pyo' found under directory 'docs'
    warning: no previously-included files matching '*.pyc' found under directory 'tests'
    warning: no previously-included files matching '*.pyo' found under directory 'tests'
    warning: no previously-included files matching '*.pyc' found under directory 'examples'
    warning: no previously-included files matching '*.pyo' found under directory 'examples'
    no previously-included directories found matching 'docs/_build'
    no previously-included directories found matching 'docs/_themes/.git'
Downloading/unpacking Werkzeug>=0.7 (from flask)
  Downloading Werkzeug-0.9.4.tar.gz (1.1Mb): 1.1Mb downloaded
  Running setup.py egg_info for package Werkzeug

    warning: no files found matching '*' under directory 'werkzeug/debug/templates'
    warning: no files found matching '*' under directory 'tests'
    warning: no previously-included files matching '*.pyc' found under directory 'docs'
    warning: no previously-included files matching '*.pyo' found under directory 'docs'
    warning: no previously-included files matching '*.pyc' found under directory 'tests'
    warning: no previously-included files matching '*.pyo' found under directory 'tests'
    warning: no previously-included files matching '*.pyc' found under directory 'examples'
    warning: no previously-included files matching '*.pyo' found under directory 'examples'
    no previously-included directories found matching 'docs/_build'
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.4 in /usr/local/lib/python2.7/dist-packages (from flask)
Downloading/unpacking itsdangerous>=0.21 (from flask)
  Downloading itsdangerous-0.23.tar.gz (46Kb): 46Kb downloaded
  Running setup.py egg_info for package itsdangerous

    warning: no previously-included files matching '*' found under directory 'docs/_build'
Requirement already satisfied (use --upgrade to upgrade): markupsafe in /usr/local/lib/python2.7/dist-packages (from Jinja2>=2.4->flask)
Installing collected packages: flask, Werkzeug, itsdangerous
  Running setup.py install for flask

    warning: no files found matching '*' under directory 'tests'
    warning: no previously-included files matching '*.pyc' found under directory 'docs'
    warning: no previously-included files matching '*.pyo' found under directory 'docs'
    warning: no previously-included files matching '*.pyc' found under directory 'tests'
    warning: no previously-included files matching '*.pyo' found under directory 'tests'
    warning: no previously-included files matching '*.pyc' found under directory 'examples'
    warning: no previously-included files matching '*.pyo' found under directory 'examples'
    no previously-included directories found matching 'docs/_build'
    no previously-included directories found matching 'docs/_themes/.git'
  Running setup.py install for Werkzeug

    warning: no files found matching '*' under directory 'werkzeug/debug/templates'
    warning: no files found matching '*' under directory 'tests'
    warning: no previously-included files matching '*.pyc' found under directory 'docs'
    warning: no previously-included files matching '*.pyo' found under directory 'docs'
    warning: no previously-included files matching '*.pyc' found under directory 'tests'
    warning: no previously-included files matching '*.pyo' found under directory 'tests'
    warning: no previously-included files matching '*.pyc' found under directory 'examples'
    warning: no previously-included files matching '*.pyo' found under directory 'examples'
    no previously-included directories found matching 'docs/_build'
  Running setup.py install for itsdangerous

    warning: no previously-included files matching '*' found under directory 'docs/_build'
Successfully installed flask Werkzeug itsdangerous
Cleaning up...

使い方は、検索すると出てくるかと思います

pythonが動くのが遅いなぁ…という場合は

ラズベリーパイのCPUを高速にすることはできませんが、高速なさくらのVPSを借りてそれにUbuntuをインストールすることで、ラズベリーパイとほぼ同じ手順で高速なサーバを構築することができます(^O^)

自分も使っていますが、CPUはラズベリーパイのおよそ10倍速いのでブログソフトWordpressもサクサク動いてとても快適です(・∀・)
ラズベリーパイでサーバ構築の練習をし、VPSで高速安定なサーバを構築するとCPUやメモリも自由に使え、勉強する時間も少なく安定したサーバが作れるためコスパが最高だと思います


それかメモリ1ギガで月490円のDTIのVPSだと、ラズベリーパイ+SDカード+電源をそろえる5000円で10ヶ月はVPSが使えるので、wordpressを使ってブログの「運用」まで考えるならVPSの方がいいです


おすすめアイテム!

この記事の内容はラズベリーパイを使うと実際に試すことができます!
記事を読むだけでなく「実際に自分の手を動かして体験してみる」ことがコンピュータに詳しくなる近道です!

2018年09月現在、ラズベリーパイ3 モデルBプラスが日本で手に入るコスパが良い最新モデルです!
Raspberry Pi 3 Model B+ element14 スターターセット BASIC ラズベリーパイ3 モデルBプラスではUSB機器からラズベリーパイのOSを起動することができるようになりました。 下記のようなUSBポータブルHDDを使うと、ラズベリーパイで大容量の音楽プレイヤができます! マイクロSDで同じ容量のものを買うより安いのでおすすめです! https://www.amazon.co.jp/dp/B06X3VSKJ7/ref=as_li_ss_tl?_encoding=UTF8&psc=1&linkCode=ll1&tag=aza2limemo-22&linkId=25f18e2118942a9614514a6c0b0e535c

ラズベリーパイで最先端のアプリ開発やAI研究をしているけど動作が遅いなぁ…という場合は

ラズベリーパイは安価なPCとしては高速ですが、通常のデスクトップPCと比べると性能は劣ります。

ラズベリーパイで最先端のアプリ開発やAI研究をしたいと思ったなら、Ubuntuが動作するデスクトップパソコンがおすすめです! Ubuntuはラズベリーパイとほぼ同じように操作できます!
UbuntuがインストールされているPCはCPUが高速でメモリが多く、ストレージもSSDなのでストレスなくアプリ開発を行うことができます!
グラフィックボードも搭載されており、膨大な計算を必要とするAI研究も可能です!

ラズベリーパイでは数日かかるような膨大な計算も、短時間で終えることができます!

パワフルなPCを使用すると素早く最先端のアプリ開発が可能です。これはIT業界を志望する場合の強い武器になります!
Dell デスクトップパソコン XPSタワー Core i7プレミアムモデル 18Q46/Windows10/16GB/256GB SSD+2TB HDD/GTX1050Ti
スポンサーリンク

最後まで記事をお読みいただきありがとうございます!